NSX Manager is not Visible in VCFA Connections after VCFA redeployment
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NSX Manager is not Visible in VCFA Connections after VCFA redeployment

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Article ID: 421607

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite) VCF Automation

Issue/Introduction

After redeploying VCFA to correct an incorrect DNS entry, one of the NSX Managers stopped appearing under:

  • Provider Portal > Administration > Connections > vCenter

  • Provider Portal > Administration > Connections > NSX Manager

Despite this, the VCFA component was already managed under Fleet Management > Lifecycle, and data collection for both vCenter and NSX was functioning correctly from VCF Operations.
Manually attempting to sync NSX-T Edge information through:
Inventory > VCF Instance > Actions > Sync Inventory (with Enable Edge cluster sync selected) Fails with error 'Import operation for sync with id <request_id> failed internally" pointing towards SDDC

Environment

VCF Automation 9.0.1
VCF Operations 9.0.1

Cause

The NSX Manager was incorrectly marked in an ERROR state by SDDC, preventing it from being listed under VCFA connections.

Resolution

The NSX Manager status was updated to ACTIVE directly in the SDDC Manager database, restoring visibility under VCFA Connections.

Steps:

  1. Take Snapshot of SDDC Manager VM
  2. SSH to SDDC manager with vcf and su to root
  3. Connect to platform database
    psql --host=localhost -U postgres -d platform

  4. Update the NSX component status to ACTIVE
      update nsxt set status = 'ACTIVE' where cluster_fqdn = '<VCFA_FQDN'; 

  5. Confirmed that the NSX Manager started appearing again under Connections in VCFA.

 

Additional Information

https://knowledge.broadcom.com/external/article/417180
https://knowledge.broadcom.com/external/article/413440