UDP Fails with Permission denied Error
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UDP Fails with Permission denied Error

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Article ID: 421576

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Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

When executing a process, a delay is seen when reaching an hco/checkout step.

The checkout completes, but does not proceed as expected.

The session will remain open for approximately two hours and the post deployment script does not complete.

After setting logging to level 5 and recreating the issue, the following is seen:

-- SEND OBJIDMessage:   HSRV_E_FA <FILE_NAME> Permission denied. It might have no access, can't replace read_only file or the file is being used by another process. 
-- I00060080: Check out summary: Total: 1 ; Success: 0 ; Failed 1 
-- SEND STATUS:  USER_ERROR_START 

Environment

All versions of Harvest

Cause

There is some issue with the file being checked out or the folder containing the file

Resolution

It will be good to confirm if the checkout is successful outside of the script.

If the error persists outside of the script, we suggest looking at the following:

1) Size of the checked out file

If it is a large file then we could be running into some kind of performance issue moving the file through your network.

2) Size of the folder containing the above file

A large containing folder could also cause a long delay in checking out the above file.

3) Permissions of the user connecting via the agent

If the user connecting via the agent does not have permission to write to the specified file then that can cause this error.

4) Ensure the file is not in use in the environment