Timesheet Integration has warnings Rally portfolio item XXXXXX not synced
search cancel

Timesheet Integration has warnings Rally portfolio item XXXXXX not synced

book

Article ID: 421556

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When running Timesheet Integration job there are Rally portfolio item warnings like this:
Rally portfolio item XXXXXX not synced with allowed Clarity investment or Clarity investment not configured properly or Clarity investment type is not specified under FCA 'Capital Actual Clarity Investment'

Environment

Clarity with Frictionless Time

Cause

  • Feature is not set up correctly for syncing
  • This is not a blocking issue, however time may have to be entered manually until the reason is addressed
  • This is usually a single Feature (Portfolio Item) that does not exist in Clarity for the Feature (PI) in Rally.
  • The message would only typically be thrown for a non-configured type of CIT/Project on the first run.
  • All other runs, it is typically an instance (one specific Feature) that does not exist in Clarity

Resolution

  • Check Investment Type Mapping  - Ensure the Clarity investment (Project, Custom Investment Type, etc.) linked to the Rally Portfolio Item has an Investment Type defined.
  • Verify that the Investment Type of the Rally-linked Clarity investment is included in the list of allowed values for this Integration.
  • Check that the Feature (parent Rally Portfolio Item to the Stories within the time period ) has been synchronized to Clarity to the corresponding CIT or Project.
  • If the Investment Type is missing, add it to the allowed list and re-run the Synchronize Mapped Information Job
  • Then next time you run Timesheet Integration job you should no longer see a warning about this Rally item