Integration does not show any data for VMs but does for ESXi hosts.
Environment
vRealize Log Insight / Aria Operations for Logs 8.x
Cause
ESXi hosts are configured to forward their syslogs after integrating with a vCenter.
For VMs, agents need to be installed to configure the VMs to forward along their logs.
Resolution
Confirm an agent is communicating:
Log in to the Aria Operations for Logs.
Click the Configuration (three bars) icon or the Administration link in the top right corner.
Go to Management and select Agents.
The default view shows all agents that have communicated with the cluster.
Additional Information
If one does not find any VM logs, either the logs are not being forwarded or the VM's agent needs to be reviewed to ensure it is configured and communicating correctly.