Cluster Unable to Communicate With Harbor Kubernetes Services
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Cluster Unable to Communicate With Harbor Kubernetes Services

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Article ID: 421531

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Updated On:

Products

VMware vSphere Kubernetes Service

Issue/Introduction

After performing configuration steps according to Integrate TKG Service Clusters with a Private Container Registry, your Supervisor Cluster is still unable to provision pods or communicate with Harbor. 

Environment

VMware VKS

Cause

The IP Pool for the Port Group the Supervisor Cluster is using is is exhausted. This can be viewed from within the vSphere GUI or within the Supervisor Node CLI via a k describe command:

Resolution

Clear up used IPs in the pool or add more IPs to the pool.