Service account for vRSLCM in disconnected state in the SDDC Manager
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Service account for vRSLCM in disconnected state in the SDDC Manager

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Article ID: 421524

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

  • Remediation of the account fails with error similar to:

Message: Unable to update vCenter password in vRSLCM: <vCenter_FQDN>
Remediation Message: Reference Token: 3UCAPP 
Cause: Unable to update vCenter password in vRSLCM

 

Environment

VCF 5.x

Cause

  • From the /var/log/vmware/vcf/operationsmanager.log we see that the SDDC is able to retrieve the credentials it requires to complete the remediation API on the vRSLCM component:

Found credential with ID: <GUID> for entityId: null, entityType: VRSLCM credentialType: API

  • The SDDC then uses an API to get the system details from vRSLCM:

Request URI: https://<FQDN of Aria Suite Lifecycle>/lcm/lcops/api/v2/settings/system-details

  • This however fails due to incorrect credentials:

"401 UNAUTHORISED"  "Unable to connect using password for <VCENTER FQDN> in VRSLCM_SSO"

 

Resolution

  • It's necessary to trace the credentials being used by SDDC for this task
  • In the SDDC Developer Center, filter for 'credential' and use the API to list the credentials
  • Find the entry that corresponds to the <GUID> found in the logs earlier 

i.e. Found credential with ID: <GUID> for entityId: null, entityType: VRSLCM credentialType: API

  • Normally this should map to the vcfadmin user
  • Test the vcfadmin user credentials in vRSLCM
  • If this fails, update the password for the vcfadmin user in vRSLCM to match the password stored on the SDDC Manager
  • Attempt the remediation of the service account again in SDDC Manager -> Password Management