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Email id does not exist for the user when manually notifying a group or contact that does not have a email address

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Article ID: 42149

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

ERROR - Email id does not exist for the user(s): [username]

Cause

The design was changed back in r14.1, the error message is expected behavior.

Environment

CA Service Desk Manager 17.1 and higher.

Resolution

To send a manual notification to a group or contact with no email address assigned.

After selecting manual notification

Set "Preferred Method" to "Notification" on the manual notification screen.

The recipient can view the notification through the CA Service Desk UI

Select VIEW

Select LOG READER

Additional Information

We recommend to set the purge function with the Notify Log Header by the archive and purge function. 

Administration tab > Archive and Purge > Archive and Purge rule > Notify Log Header.

The Notify Log Header rule in the archive and purge has been set 'Inactive'.

It is necessary to set the active to perform the rule in order to use it. 

The scheduling settings can be decided from the end user's business operation for the purge.

For more information about Archive and Purge, please documentation below:

Archive and Purge Historical Data