Unable to Update vCenter Licensing for VMware Aria Automation Orchestrator Due to vSphere+ Subscription Lock
search cancel

Unable to Update vCenter Licensing for VMware Aria Automation Orchestrator Due to vSphere+ Subscription Lock

book

Article ID: 421488

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Administrators are unable to update the vCenter Server license to clear an evaluation-expiry warning displayed in VMware Aria Automation Orchestrator. Attempts to apply a new on-premises license key fail because the vCenter Server remains linked to a vSphere+ cloud subscription, preventing local license management.

Environment

Aria Orchestrator 8.18.x
VMware vCenter Server 8.x

Cause

Aria Orchestrator 8.18.x doesn't support the vSphere+ subscription license.

Resolution

  • Power off the Cloud Gateway VM.

  • Take a powered-off snapshot of the vCenter Server to maintain a rollback point.

  • Download and run the vCenter disconnection script provided in Broadcom KB 323680

  • Allow the script to complete; it will remove the cloud-subscription enforcement flag from the vCenter database.

  • Assign the new on-premises license key directly to the vCenter Server.

  • Verify that the updated licensing propagates and that the evaluation warning in VMware Aria Automation Orchestrator is cleared.

Additional Information

Note: If the problem persists or you need help with the steps, contact the VMware vCenter team by creating a support case.