After upgrade to ESXi 8.0, firmware version shows "unknown" in Skyline Health Check
search cancel

After upgrade to ESXi 8.0, firmware version shows "unknown" in Skyline Health Check

book

Article ID: 421482

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Syncing the HCL through Lifecycle Manager -> Actions -> Sync HCL fails to with a generic "internal server error"

/var/log/vmware/analytics/analytics.log shows the following:

phStageLogDrainerTaskExecutor-2  INFO  org.bouncycastle.jsse.provider.ProvTlsClient [client #348987 @5140c526] disconnected from vcsa.vmware.com:443
phStageLogDrainerTaskExecutor-2  INFO  apache.http.impl.execchain.RetryExec I/O exception (java.net.SocketException) caught when processing request to {s}->https://vcsa.vmware.com:443: Connection reset
phStageLogDrainerTaskExecutor-2  INFO  apache.http.impl.execchain.RetryExec Retrying request to {s}->https://vcsa.vmware.com:443
phStageLogDrainerTaskExecutor-2  INFO  org.bouncycastle.jsse.provider.ProvTlsClient [client #348988 @30c3ef06] opening connection to vcsa.vmware.com:443
phStageLogDrainerTaskExecutor-2  WARN  org.bouncycastle.jsse.provider.ProvTlsClient [client #348988 @30c3ef06] raised fatal(2) internal_error(80) alert: Failed to read record java.net.SocketException: Connection reset

 

wget to https://vcsa.vmware.com:443 succeeds on connection but then errors out due to SSL connection reset

Environment

vCenter Server 8.0

ESXi 8.0

Cause

Connection from vCenter Server to vcsa.vmware.com is blocked by physical firewall, specifically for SSL traffic

Resolution

Update firewall rules on physical firewall to allow SSL traffic from vCenter Server to vcsa.vmware.com

Additional Information

Additional connectivity tests can be found in vSphere Health Service - Internet Connectivity Check