TrustedHost IP Address Not set in the Policy Store
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TrustedHost IP Address Not set in the Policy Store

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Article ID: 421465

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Updated On:

Products

SITEMINDER CA Single Sign On Agents (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign-On

Issue/Introduction

Running Policy Server, looking at the IpAddr field of a Trusted Host, the IpAddr field has no value when the one created for the AdminUI has a value.

How to get a value for the IpAddr from a Trusted Host?

This is to identify the agent, in case of doubt about the name, for example.

Cause

The IpAddr field from an Agent trusted host is not viable, and that's mainly the reason it has no value.

Among the others:

  • The SmHost.conf file for an Agent can be used on several machines when running on Windows;
  • The Agent might be behind a load balancer at registration time.

As such, this is as expected to not see the IP value for the trustedhost when registered with the smreghost command.

The smreghost tool doesn't provide the IP.

Resolution

The XPSExplorer tool is usually used to handle directly the data from the Policy Store.

To get the trusted host and the IP:

  • OneView Monitor:

    This tool is dedicated to presenting stats for the moment of reading the statistics, not the cumulated statistics.
    That means the Agent TrustedHost name and IP for the Agent that is sending requests to the Policy Servers at the moment.
       
  • AdminUI:

    To get the data in the AdminUI "Infrastructure / Agent / Agent Instances", enable Agent Discovery (1)(2).

  • Other tools:

    There are other tools to monitor the environment and help to identify the Agent with its trusted host (3).

Additional Information

  1. Agent Discovery

  2. AgentInstance[] has an attribute named 'ACOLink' that points to an object of type 'AgentConfig' that does not exist warning in Policy Server

  3. Agent versions connecting to a Policy Server