Severity is blank when passing through Spectrum AlarmNotifier
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Severity is blank when passing through Spectrum AlarmNotifier

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Article ID: 421353

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Updated On:

Products

Network Observability Spectrum

Issue/Introduction

After upgrading we noticed that the Severity field in AlarmNotifier is blank.  This is causing issues with Service Now as tickets have a severity of OK

In the Notifier.OUT we see the Severity field is blank:

Alarm SET:

Date:             12/08/2025
Time:             16:38:12
DeviceType:       IP Device
Mtype:            Pingable
ModelName:        APingable
AlarmID:          1652
Severity:
ProbableCauseID:  10009
RepairPerson:
AlarmStatus:
SpectroSERVER:    SpectroSERVER1
Landscape:        0x100000

 

Cause

The files in the $SPECROOT/Res directory were owned by root

Resolution

All files in the $SPECROOT/Res directory need to be owned by the spectrum install user.

Here is an example command changing ownership of all files in the Res directory to the user name "spectrum"  Please run this in the Res directory.  Do not run this in $SPECROOT:

chown -R spectrum: *

Validate specifically that the files in $SPECROOT/Res/SUTILS are owned by the spectrum install owner.

You will need to restart the AlarmNotifer process for this change to take effect.

ps -ef | grep -i Notifier

kill -9 <pidofNotifier>

processd will automatically restart the Notifier process