Error "Service account for esx already exists" while deploying VCF 9.0
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Error "Service account for esx already exists" while deploying VCF 9.0

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Article ID: 421344

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Updated On:

Products

VMware Data Services Manager for VCF

Issue/Introduction

  • "Service account <svc-account-name> for esx <esx hostname> already exists" error while deploying VCF 9.0.



  • VCF Deployment was tried and failed earlier and re-using the same ESX Hosts without re-installing to attempt another VCF 9 installation.

Environment

VCF 9.x

Cause

Since the VCF installation was already attempted in the past and the same hosts are being re-used for another attempt, service accounts got created previous still exists in the Hosts and unable to create new one for this new deployment.

Resolution

  1. SSH in to the ESX Host
  2. Execute the command below and ensure the service account exists:

    esxcli system account list
  3. If account exists, remove it by running the command below:

    esxcli system account remove <vcf-svc-account-name>

    Replace <vcf-svc-account-name> with the actual user name displayed in the error message.

  4. Retry VCF installation workflow