Error "Service account for esx already exists" while deploying VCF 9.0
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Error "Service account for esx already exists" while deploying VCF 9.0

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Article ID: 421344

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • "Service account <svc-account-name> for esx <esx hostname> already exists" error while deploying VCF 9.0.



  • VCF Deployment was tried and failed earlier and re-using the same ESX Hosts without re-installing to attempt another VCF 9 installation.

Environment

VCF 9.x

Cause

Since the VCF installation was already attempted in the past and the same hosts are being re-used for another attempt, service accounts got created previous still exists in the Hosts and unable to create new one for this new deployment.

Resolution

The system account can be removed either via the ESXi Host Client or through the CLI.

Option 1: Delete via ESXi Host Client

  1. Log in to the ESXi Host Client using the root account.
  2. Navigate to Manage > Security & Users > Users.
  3. Locate and select the service account referenced in the error message.
  4. Click Remove user to remove the service account & retry the VCF installation workflow.

Reference Image:

Option 2: Delete via CLI

  1. SSH into the ESX Host
  2. Run the following command to verify if the service account exists:
    esxcli system account list
  3. If the account is present, remove it using:

    esxcli system account remove <vcf-svc-account-name>
    • Replace <vcf-svc-account-name> with the actual username displayed in the error message.

  4. After removing the account, retry the VCF installation workflow.