Upgrade Failure Due to Unsupported Timezone – US/Pacific-New
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Upgrade Failure Due to Unsupported Timezone – US/Pacific-New

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Article ID: 421242

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Updated On:

Products

VMware Aria Operations (formerly vRealize Operations) 8.x

Issue/Introduction

VMware Aria Operations upgrade may fail if any node in the cluster is configured with the deprecated timezone US/Pacific-New. This timezone alias has been removed in more recent PostgreSQL database releases, and systems using it can encounter errors during upgrade validation or database migration.

Environment

Aria Operations 8.17

 

Cause

PostgreSQL database systems no longer support the US/Pacific-New timezone, which was just an alias for America/Los_Angeles timezone. If any of the VMware Aria Operations nodes are running on VMs with US/Pacific-New timezone, upgrade might fail.

This issue impacts any Aria Operations node, including:

  • Primary node

  • Replica node

  • Data nodes

  • Cloud Proxy (if applicable)

 

Resolution

SSH to each Aria Operations node and run:

It is recommended to first take a snapshot of the appliance (without memory) before proceeding.

In the web console, log in to the appliance.

First, confirm the current timezone with the command:

timedatectl

By default, the timezone should be set to UTC.

Then, to change the timezone to e.g. PST, issue the command:

timedatectl set-timezone America/Los_Angeles

To list the available timezones, issue the command:

timedatectl list-timezones

WorkAround : Change VM timezones from US/Pacific-New to America/Los_Angeles, and then upgrade.

Additional Information

Refer Techdoc

https://techdocs.broadcom.com/us/en/vmware-cis/aria/aria-operations/8-17-1/Chunk436249168.html