Validation of HCX upgrade
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Validation of HCX upgrade

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Article ID: 421140

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Updated On:

Products

VMware HCX

Issue/Introduction

HCX UI does not come online after an upgrade reboot. 

 

Environment

HCX 

Cause

After an HCX upgrade and subsequent reboot, the UI might remain offline for longer than expected due to ongoing post-upgrade tasks, which vary in duration based on the HCX configuration.

 

Resolution

Once HCX upgrade message comes at HCX UI. To validate the completion of post upgrade tasks

Verify the completion of the post upgrade tasks by reviewing log entries in the following files. 

/common/logs/upgrade/upgrade.log 
 Validating the upgrade bundle .............................................................................. [   OK ]
  Backing-up certs, configs and database before the upgrade .................................................. [   OK ]
 Stopping all the services .................................................................................. [   OK ]
 Extracting distribution bundle ............................................................................. [   OK ]
  Installing the upgrade image ............................................................................... [   OK ]
 Updating each components version ........................................................................... [   OK ]
  Upgrade successful, restarting the HCX Manager VM .......................................................... [   OK ]

Verify the upgrade of postgres

/common/logs/postgres/postgres-startup.log

Postgres upgrade script completed

Verify the completion of the upgrade

/common/log/appliance-management/appliance-management.log

Log entry for upgrade to 4.11.3

INFO  c.v.v.s.upgrade.utils.UpgradeTask- Posted event for post upgrade bookkeeping {"upgradeStatus":{"endpointId":"##################" 
,"version":"4.11.3.0.24972695","status":"COMPLETE","message":"Upgrade successful","upgradeEndTime":1764709629000}}