Web UI is unable to connect to Secondary EEM
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Web UI is unable to connect to Secondary EEM

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Article ID: 421121

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

During an EEM failover, the AutoSys Web-UI (WCC) is unable to connect to the Eiam server and returns an "EEM down" error. While the AutoSys Scheduler (AE) might failover correctly, the WCC component fails to roll over to other available EEM hosts in the multi-write cluster.

Environment

 

  • Support Product: Autosys Workload Automation

  • Product Release: 12.1 SP1

  • Component: ATSEEM

  • EEM Version: 12.7

  • WCC Version: 12.1.1.x

 

Cause

The issue is typically caused by an environment problem where the EEM multi-write configuration becomes out of sync or corrupted, particularly following an EEM upgrade where multi-write was not undone prior to the upgrade. This can result in a "hostname is null" error in the logs when WCC attempts a failover.

Resolution

To Resolve this connectivity and failover issue, the EEM multi-write environment must be reset and certificates must be regenerated for WCC.

  • Break Multi-Write: Issue the resetprimary command on all EEM servers to break the current failover configuration.

  • Modify Certificates: Use the modifycerts command on the EEM servers to ensure certificates are valid.

  • Re-establish Multi-Write: Re-add all intended EEM servers back into the failover/multi-write configuration.

  • Redo WCC EEM Certificates: * Regenerate the WCC.key and WCC.pem files on one WCC node.

    - Copy these new files to all other WCC instances in the environment.
  • Update WCC Configuration: Use the wcc_config.sh (or .bat) utility to point WCC to all EEM hosts in the cluster using the newly generated key and pem files.

  • Verify: Restart WCC services and verify that login is successful even when specific EEM nodes are taken offline.

Note: It is must to break the  multi-write environment before upgradation in case EEM is in multi-write environment.