search cancel

CA Business Intelligence (CABI) audit data is not purged/deleted after setting a proper value for "Delete Events Older than (days)" in Central Management Console (CMC).

book

Article ID: 42112

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Issue

CA Business Intelligence (CABI) audit data is not purged/deleted after setting a proper value for "Delete Events Older than (days)" in Central Management Console (CMC).

Environment

CA Business Intelligence (CABI) 4.1

Windows 2008 or Windows 2012

Cause

Database fails to process the DELETE statement since the data bulk is too large.  For example, in a scenario where there are over 1 million rows to be deleted from the CMS ADS_EVENT table.

Resolution

1. Check the earliest audit data being stored in the CMS ADS_EVENT table. For example, 2014/08/01 which is 636 days earlier than the current date (2016/04/28).

2. Set a bigger value (i.e. 600 days) for "Delete Events Older than (days)" so that the database can process the data bulk for 36 days' data volume.

3. CMS Audit data can be expected to be deleted in a couple of days.

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component: