The alert "Fragmentation exists post PMTU realisation" is reported in the HCX UI.
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The alert "Fragmentation exists post PMTU realisation" is reported in the HCX UI.

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Article ID: 421031

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Updated On:

Products

VMware HCX

Issue/Introduction

  • An alert indicating that "Fragmentation exists post PMTU realization" was detected on the HCX appliance displayed in the HCX UI.
    Message: Fragmentation exists post PMTU realisation on applianceid : <applianceid>


  • A log indicating the percentage of fragmentation occurring is output to "/common/logs/admin/app.log".
    <timestamp> UTC [InterconnectService_SvcThread-570987, SM:servicemesh-<uuid>, J:7a366d53, , TxId: <uuid>] INFO  c.v.v.h.s.i.underlay.FCAlertsJob- Fragmentation did not reduce on applianceId: <appliance-uuid>, averageFcIncreaseRateBeforePmtuUpdatedTime: 0.7624035145848944, averageFcIncreaseRateAfterPmtuUpdatedTime: 0.5660000602747063, threshold: 0.5

Environment

VMware HCX

Cause

Once the new MTU is applied on all the data plane appliances in the service mesh, HCX appliances check if the applied MTU solved the fragmentation problem or not.
If the fragmentation still exists post applying the MTU, HCX Manager raises an alert saying "Fragments Exist post PMTU realization".

Resolution

The root cause of HCX performance issues often stems from an MTU (Maximum Transmission Unit) mismatch somewhere in the network configuration chain.
This mismatch can significantly impact data transfer speeds and overall network performance.

If the MTU of a device along the path changes during operation, fragmentation may occur.
Refer to KB379617 to resolve MTU issues between sites.

[HCX is not migrating or passing traffic over network extensions at expected speeds]
https://knowledge.broadcom.com/external/article/379617/