NSX Manager UI is not accessible as one of the NSX Managers is corrupt and needs to be replaced.
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NSX Manager UI is not accessible as one of the NSX Managers is corrupt and needs to be replaced.

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Article ID: 421029

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Updated On:

Products

VMware NSX

Issue/Introduction

  • UI of specific NSX Manager is not accessible.
  • This node may also be the owner of the VIP, rendering the UI accessed through the VIP inaccessible.
  • Services on this node may not be running, or services may not be stable (services will go down after some time), or the node may became corrupt due to storage outage.
  • The Manager is considered faulty and you would like to replace it. 

Environment

VMware NSX

Cause

Unstable services will block access to the UI.

Resolution

Faulty node can be replaced through the UI:

  1. Using one of the healthy nodes, access the UI.
  2. Browse to System - Appliances to identify the faulty node.
  3. Note the IP address and FQDN of the faulty node. 
  4. Delete the faulty node - click on "ACTIONS" drop down menu, and select "Delete".
  5. Make sure the faulty node VM is powered off in vSphere. 
  6. Use the UI, and "ADD NSX APPLIANCE" tile in System - Appliances to add a new node into the cluster. 
    See Deploy NSX Manager Nodes to Form a Cluster from the UI for more details. 
    To deploy a node from the OVA, please see: Install NSX Manager and Available Appliances.
  7. Wait a few moments for the cluster to stabilize.

Alternatively, you can detach the faulty node from the cluster using the CLI following the steps in KB article NSX Manager Node Replacement Using Manual Deployment When Compute Manager Is Not Connected.

Additional Information

For a faulty NSX Manager in VCF environment, please see KB article Replacing a faulty NSX-T manager node in a VCF environment.