Some or all vSAN disks on a vSAN host report to be absent in vSAN Disk Management
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Some or all vSAN disks on a vSAN host report to be absent in vSAN Disk Management

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Article ID: 420998

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • A few or all vSAN disks on a vSAN host may report to be absent in vSAN Disk management and vSAN Skyline Health.

  • In vSphere Client > Select affected host > Configure > Storage Devices  - It can be observed that the vSAN disk(s) is missing.

Environment

VMware vSAN 7.x

VMware vSAN 8.x

VMware vSAN 9.x

Cause

  • From the host's hardware management console it can be found that the disk storage controller has failed.

  • Since the storage controller has failed on the hardware level, the disks attached to it would also not be visible on the hardware end.

  • If the disks are not visible on the hardware level, then it would also not be visible on the ESXi host and vSAN end.

  • Due to this, the vSAN disks appear as absent in vSAN disk management.

Resolution

  • Engage the hardware vendor to investigate the storage controller failure and replace the controller.

  • Once the controller is fixed, the vSAN disk should be visible once again on the host.

Additional Information

Note:

  • In certain instances, the storge controller would still be visible on the ESXi host end (vSphere Client > affected vSAN host > Configure > Storage Adapter > affected vmhba), but not visible at all at the hardware end.

  • Even in this case, the hardware issue must be investigated and resolved first.