Azure Cost History Data missing after updating an expired Service Principal
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Azure Cost History Data missing after updating an expired Service Principal

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Article ID: 420933

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Updated On:

Products

CloudHealth

Issue/Introduction

During Azure account lifecycle occasionally an access key for a Service Principal will expire for a period of time and will need to be updated.  
If the period of expiration exceeds the current month then, upon updating the key, there may be missing cost data for the prior months when the key was in the expired state.

Environment

Azure
Cost History Reporting
Service Principal 
Key Expiration 

Cause

Prior month Azure cost may not be collected when an Azure Service Principal key has expired and is subsequently restored. 

Resolution

This is a known issue and work is planned to automate cost backfill for this use-case with an estimate of early 2026.  
In the interim, customers can enter a support ticket showing the gap and accounts.  Our support team will work to re-collect and process any recent missing months where the cost is still collectable from Azure.