Connecting a Fleet Management appliance to VCF Operations fails and vmware_vrlcm.log contains 'Error occurred while pushing service registry to'
search cancel

Connecting a Fleet Management appliance to VCF Operations fails and vmware_vrlcm.log contains 'Error occurred while pushing service registry to'

book

Article ID: 420856

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Attempting to connect Fleet Management to VCF Operations(VCF Ops) following Register the VCF Operations fleet management Appliance with VCF Operations ,certificate prompt is accepted and the wizard disappears while leaving the status of Fleet Management in 'not connected' state.

In '/var/log/vrlcm/vmware_vrlcm.log' on the Fleet Management appliance, you notice following error.

Error occurred while pushing service registry to 'hostname' of VCF Operations
java.io.IOException: Server returned HTTP response code: 400 for URL: https://hostname/casa/capabilities

Environment

VCF Operations 9.x

Cause

VCF 9 requires FQDN be set as the 'hostname' of all appliances during deployment.

Resolution

To resolve the issue, follow these steps to update the hostname of the VCF Ops node to its FQDN:
  • Login to the admin UI of the VCF Operations as admin user (https://<FQDN_IP_VCF_OPS>/admin)
  • Take the VCF Ops cluster offline.
  • Take snapshots of all the nodes.
  • Update the hostname of VCF Ops to a (forward and reverse) resolvable FQDN (instead of using a short name or IP address) using the How to change a node hostname in Aria Operations KB.
  • Bring the VCF Ops cluster back online from the admin UI.
  • Attempt to connect Fleet Management once again.