VMware Identity Manager Directory Intermittent Sync Failures
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VMware Identity Manager Directory Intermittent Sync Failures

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Article ID: 420854

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

In VMware Identity Manager, sync logs are not updating.

Multiple email notifications are received indicating directory synchronization failures throughout the day. However, when a manual directory synchronization is performed, the operation successfully completes.

Environment

VMware Identity Manager 3.3.7

Cause

OpenSearch is only allocated maximum 1,000 shards by default.

In /opt/vmware/horizon/workspace/logs/analytics-service.log we see errors like:

reason":"Validation Failed: 1: this action would add [10] total shards, but this cluster currently has [1000]/[1000] maximum shards open;

Resolution

Please follow the resolution section of After upgrading to vIDM 3.3.7, user dashboard reporting and Active Directory sync log are not updating: the cluster currently has the maximum number of shards open KB article.