"No data to show" error when adding a metric to a specific physical switch.
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"No data to show" error when adding a metric to a specific physical switch.

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Article ID: 420833

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Updated On:

Products

VCF Operations for Networks

Issue/Introduction

It is observed in AON UI that "No data to show" error when adding a metric to a specific physical switch.

 

Environment

VCF Operations for Networks

Cause

A firewall may be blocking connectivity between the AON collector and the physical switch.

Resolution

Please make sure following things for these switches where we do not see metrics.

1. The problematic switch is reachable from the AON collector.

support@aria-networks-collector:~$ ping <IP_ADDRESS>

2. Make sure there is not firewall rule blocking between the AON collector and the physical switch.

support@aria-networks-collector:~$ nc -v <IP_ADDRESS> 443

support@aria-networks-collector:~$ nc -v -u <IP_ADDRESS> 161

3. Make sure SNMP credentials (community string for SMNP v2, username/password for v3) is same for all switches.

4. Make sure snmpwalk is working from the AON collector to the physical switch.

support@aria-networks-collector:~$ snmpwalk -v2c -c <community_string> <IP_ADDRESS>  .1.3.6.1.2.1.31.1.1.1.6

support@aria-networks-collector:~$ snmpwalk -v3 -l authNoPriv -u <username> -a <MD5|SHA> -A <authphrase> <IP_ADDRESS>  .1.3.6.1.2.1.31.1.1.1.6