Unable to login to HCX Manager with a non-local user account.
search cancel

Unable to login to HCX Manager with a non-local user account.

book

Article ID: 420823

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

HCX Manager login with a non-local user account fails with the following error: Invalid username or password, or too many active sessions. Health check on the HCX manager shows failure in name resolution (under ICMP test for vCenter).

Following exception is logged on the HCX manager in /common/logs/admin/web.log


Environment

VMware HCX

Cause

  • This exception indicates an issue while querying the lookup service (vCenter) and shows an UnknownHostException suggesting name resolution issue. It was found that the DNS queries were going to an old DNS server that was no longer operational despite the HCX manager having new primary and secondary DNS configured from GUI (Administration > Networking).

  • The appliance had old/stale DNS configured which was verified by running "resolvectl status" command on the HCX manager root shell. 

Resolution

Rebooting the HCX manager appliance fixed the DNS configuration/realization issue and the HCX manager got the DNS that was configured from the GUI.