Host reports "The host does not have sufficient CPU resources to satisfy the reservation" when resources are available
search cancel

Host reports "The host does not have sufficient CPU resources to satisfy the reservation" when resources are available

book

Article ID: 420796

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • During virtual machine migration or power on operation the task fails due to insufficient resources
  • Following error is presented:
    The host does not have sufficient CPU resources to satisfy the reservation. The host host-XXX can not satisfy the requested CPU resources of XXXX MHz. (larger value) Available CPU resources on the host: XXXX MHz. (lesser value)
  • Target host is empty or has been verified to have sufficient resources

 

Environment

7.x
8.x

Cause

The vCenter Server uses outdated resource availability data cached from the host, which is significantly lower than the actual available capacity reported by the ESXi VMkernel.

Resolution

Check the true available capacity on the ESXi host via SSH:

  1. Connect via SSH to the target ESXi host
  2. Run the following command:
    root@esxi#] vsish -e get /sched/groups/4/stats/capacity

    Sample output:
    [root@esxi:~] vsish -e get /sched/groups/4/stats/capacity
    group-capacity {
    cpu-reserved:0 MHz
    cpu-unreserved:68300 MHz
    mem-reserved:0 KB
    mem-unreserved:242200232 KB

If the cpu-unreserved value is significantly higher than the value reported in the vCenter error message, the issue is synchronization, proceed to steps below to resolve

The synchronization issue can be resolved by forcing the host to re-register its resource state with the vCenter Server.

  1. Reboot the target ESXi host 

    • Note: This is the most effective method, as it clears all management agent states and forces a clean inventory refresh upon connection.

  2. If a reboot is disruptive, an alternative is to Disconnect and Reconnect the host in the vSphere Client:

    • Right-click the host Connection > Disconnect.

    • Wait 60 seconds.

    • Right-click the host Connection > Connect.

  3. Once the host status is green and connected re-attempt the VM operation.