After upgrading ServiceNow ITSM plugin to 9.0, catalog forms are not loading as expected in the ServiceNow native UI or service portal.
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After upgrading ServiceNow ITSM plugin to 9.0, catalog forms are not loading as expected in the ServiceNow native UI or service portal.

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Article ID: 420747

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When viewing catalog items that are sourced from Aria Automation in ServiceNow, the forms are blank and do not show the selection fields

Environment

ServiceNow (Zurich build), with Aria Automation ITSM plugin v9.0

 

Cause

Missing role in the Admin role that is now required for ServiceNow Zurich build and higher

Resolution

Add the "snc_required_script_writer_permission" role to the Admin Role in ServiceNow as described in documentation available for the VCF Automation Plugin (v9.0 or higher) available at https://store.servicenow.com/