NimServerSession communication error in maintenance_mode logs
search cancel

NimServerSession communication error in maintenance_mode logs

book

Article ID: 420734

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The following error is observed regularly in the maintenance_mode probe log:

 

ERROR [attach_socket, com.nimsoft.nimbus.NimServerSession] (2) communication error, I/O error on nim session (S) com.nimsoft.nimbus.NimServerSession(Socket[addr=/(IP ADDRESS),port=(port),localport=(port)]): Connection reset 

There does not appear to be any issue with maintenance_mode probe functionality but the error occurs repeatedly every few minutes.

Environment

  • DX UIM - Any Version
  • Multiple NAS probes (any version) deployed across hub SSL tunnels
  • maintenance_mode_address key is configured on secondary NAS to point to primary hub maintenance_mode probe

Cause

Normal tunnel behavior

Resolution

This error is benign; it occurs when the remote NAS probes request the schedules from the maintenance_mode probe and is an artifact of the way tunnel communications work.

The technical explanation is that the other side of the tunnel has abruptly closed its session at the end of the communication. This is normal behavior for tunnels, and in some contexts this will generate an extra error message in probe logs.

This is working as designed and this error can be ignored.