Error “Failed to propagate configuration to CP” when enabling log collection using collector/group in VMware Cloud Foundation (VCF) Operations 9.x
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Error “Failed to propagate configuration to CP” when enabling log collection using collector/group in VMware Cloud Foundation (VCF) Operations 9.x

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Article ID: 420700

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Attempting to configure Administration > Integration > VCF Adapter > expand VCF Instance > Edit vCenter Server Endpoint > Log Operations and enabling “Activate log collection” under Collect Logs (using the “Collect logs using the collector/group” option) completes successfully.
  • However, under Infrastructure Operations > Configurations > Log Collection, an error appears stating “Failed to propagate configuration to CP.”

  • You will see similar errors in  vcf-log-forwarder/log-forwarder.log in Cloud proxy 

    ERROR c.v.l.l.c.LogCollectionConfigScheduler:### - Error while fetching and applying log collection configurations.
    com.vmware.log.forwarder.httpclient.APIException: Got status 503 while retrieving session.
    at com.vmware.log.forwarder.logservercredentials.LogServerSession.refreshSession(LogServerSession.java:##)
    at com.vmware.log.forwarder.logservercredentials.LogServerSession.getSession(LogServerSession.java:##)


  • You will see similar errors in  /var/log/HAproxy-traffic.log in cloud proxy 

    localhost haproxy[#####]: Server PrxyRC_VRLI_BE/VRLI_2 is DOWN, reason: Layer4 connection problem, info: "Connection refused", check duration: 156ms. 0 active and 0 backup servers left. 0 sessions active, 0 requeued, 0 remaining in queue.
    localhost haproxy[#####]: backend PrxyRC_VRLI_BE has no server available!

Environment

VCF Operations 9.0.1
VCF Operations for logs 9.0.1

Cause

This issue is caused by firewall restrictions, as the necessary ports (9543, 514, 6514, 1514) are not open between the cloud proxy and all VCF operations for log nodes, as detailed in the port requirements documentation.

Resolution

  • To resolve this issue, ensure the required ports (9543, 514, 6514, 1514) are open between the cloud proxy and all VCF operations for log nodes.
  • Refer to the port requirements documentation for more details