Multiple email alerts for "Platform Health: Data Source Failed" from VCF Operations for Networks, although no apparent problem with the data source when checked from the GUI
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Multiple email alerts for "Platform Health: Data Source Failed" from VCF Operations for Networks, although no apparent problem with the data source when checked from the GUI

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Article ID: 420562

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Updated On:

Products

VCF Operations for Networks

Issue/Introduction

Multiple email alerts for "Platform Health: Data Source Failed" from VCF Operations for Networks, although no apparent problem with the data source when checked from the GUI

NOTE:  VCF Operations for Networks was formerly named Aria Operations for Networks (AON), and prior to that was named vRealize Network Insight (vRNI).

Environment

VCF Operations for Networks 6.14.1 and prior

 

Cause

The following is a log signature which can be found in the files ending in ".log.error" in the Collector node at the path /var/log/arkin/collector/

####-##-##T##:##:##.684Z ERROR common.utils.CommonUtils NSXT_############.####.####.com_########## logException:2680 Error in obtaining LogicalPortOperationalStatus for manager https://############.####.####.com:443

 

Resolution

The root cause of this issue is being fixed in VCF Operations for Networks 6.14.2 and 9.0.1

As a temporary workaround, reboot the Collector node. 

The frequency of the alerts should begin to subside and the time that this takes depends on the size of the NSX inventory, but you should expect to see symptom relief within 3 hours of the reboot.