Connect to an Online Depot for VCF Fleet Management fails with the error "Error in setting Online depot configuration"
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Connect to an Online Depot for VCF Fleet Management fails with the error "Error in setting Online depot configuration"

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Article ID: 420533

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Updated On:

Products

VCF Operations

Issue/Introduction

  • Connecting to an Online Depot for VCF Fleet Management fails with the error "Error in setting Online depot configuration". Use the following documentation as a guide Connect to an Online Depot for VCF Operations fleet management.
  • Errors in /var/log/vrlcm/vmware_vrlcm.log in Fleet Management are similar to :
    INFO vrlcm[###] [http-nio-8080-exec-6] [c.v.v.l.l.s.SettingsServiceImpl]  -- manifest url : https://dl.broadcom.com/<token>//PROD/metadata/manifest/v1/vcfManifest.json
    ERROR vrlcm[####] [http-nio-8080-exec-6] [c.v.v.l.u.DownloadHelper]  -- Download failed.URL : https://dl.broadcom.com/<token>//PROD/metadata/manifest/v1/vcfManifest.json, Connect to dl.broadcom.com:443 [dl.broadcom.com/###.###.###.###, dl.broadcom.com/###.###.###.###, dl.broadcom.com/####:####:####:####:####:####:####:####, dl.broadcom.com/####:####:####:####:####:####:####:####] failed: Network is unreachable (connect failed)
  •  Additional errors in /var/log/vrlcm/vmware_vrlcm.log in Fleet Management are similar to :
    ERROR vrlcm[####] [pool-3-thread-44] [c.v.v.l.p.c.m.t.CloudMarketplaceSyncTask]  -- Sync operation failed: Error while fetching details from cloud Marketplace. Hence failing task. Disconnected Environment or connection issue.
    ERROR vrlcm[####] [pool-3-thread-44] [c.v.v.l.p.c.m.t.CloudMarketplaceSyncTask]  -- Exception occurred :: com.vmware.vrealize.lcm.common.marketplace.exceptions.MarketPlaceException: Error while fetching details from cloud Marketplace. Hence failing task. Disconnected Environment or connection issue.
    INFO vrlcm[####] [pool-3-thread-44] [c.v.v.l.p.a.s.Task]  -- Injecting task failure event. Error Code : 'LCMMARKETPLACE13101', Retry : 'true', Causing Properties : '{ CAUSE ::  }' com.vmware.vrealize.lcm.common.marketplace.exceptions.MarketPlaceException: Error while fetching details from cloud Marketplace. Hence failing task. Disconnected Environment or connection issue.
  • Further errors found in /var/log/vrlcm/vmware_vrlcm.log in Fleet Management are similar to :
    INFO vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.l.c.CertificateManagementController]  -- Request received to get certificate from https://dl.broadcom.com
    INFO vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.l.s.CertificateManagementService]  -- Fetching certificate from https://dl.broadcom.com
    INFO vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.u.CertificateUtil]  -- Endpoint : https://dl.broadcom.com
    ERROR vrlcm[####] [http-nio-8080-exec-9] [c.v.v.l.u.CertificateUtil]  -- IOException occurred - connect timed out

Environment

VCF Fleet Management 9.0.x

Cause

Firewall was blocking traffic for VCF Fleet Management.

Resolution

Ensure the network firewall is not blocking traffic for VCF Fleet Management IP/FQDN and the listed URLs available in the KB: Unable to Register License in VCF Operations in Connected Mode.