NCM login does not work
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NCM login does not work

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Article ID: 420496

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Updated On:

Products

VMware Smart Assurance Network Observability

Issue/Introduction

NCM login screen does not pop up, error observed is

01 Dec 2025 16:09:27,183-[AWT-EventQueue-1] ERROR com.powerup.configmgr.client.app.util.ExceptionHandler [] - java.lang.IllegalArgumentException: Illegal pattern character 'R'
    at java.base/java.text.SimpleDateFormat.compile(SimpleDateFormat.java:849)
    at java.base/java.text.SimpleDateFormat.initialize(SimpleDateFormat.java:657)
    at java.base/java.text.SimpleDateFormat.<init>(SimpleDateFormat.java:628)
    at java.base/java.text.SimpleDateFormat.<init>(SimpleDateFormat.java:603)

Environment

All supported NCM versions 

Cause

NCM User cache was modified in local machine from where NCM is launched. 

Resolution

  1. Go to <BASEDIR (C)>\Users\<UserName>\ncm0\var\cache in local machine, rename message.log file
  2. Clear Java cache as following
    1. Login to CMD 
    2. Run javaws -clearcache for java or javaws -Xclearcache for OpenWebstart.
  3. Launch Thick or Thin client, login prompt will now appear for login. 
  4. Provide Username and Password