Low bandwidth causes vMotion failure: "The migration was cancelled ..."
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Low bandwidth causes vMotion failure: "The migration was cancelled ..."

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Article ID: 420478

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • vMotion operations fail with the listed errors after becoming stuck at 20%-30% completion for approximately 30 minutes:

     "The migration was cancelled because the amount of changing memory for the VM was greater than the available network bandwidth, meaning the migration was not making forward progress. Please attempt the migration again when the VM is not as busy or more network bandwidth is available."

  • A newly created, powered-on VM without a Guest OS can be vMotioned to other ESXi hosts, but the operation is very slow.
  • The following failure is observed on the source or target ESXi host:

     <YYYY-MM-DD> <Time> In(###) vmkernel: cpu40:####### opID=########)VMotion: ####: ################### <D/S>: Estimated network bandwidth 0.7## MB/s before failure

Environment

VMware vSphere ESXi 8.0.x

Cause

Low network bandwidth throughput is mostly caused by physical switches, ESXi network adapter drivers and firmware, or traffic shaping.

Resolution

Engage the physical switch vendor to inspect the switches.

Verify the physical NICs being used for vMotion have appropriate speed to do the vMotion - preferably 10Gb or more. 

You can open a Broadcom support case (as outlined in Creating and managing Broadcom support cases) to check the network adapter drivers, firmware, and other components. (Refer to the Knowledge Base article 332734 for details)