Unable to recreate vSAN cluster due to "General vSAN error"
search cancel

Unable to recreate vSAN cluster due to "General vSAN error"

book

Article ID: 420464

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

vSAN cluster configuration may fail during reconfiguration or rollback after an upgrade. The vSphere Client UI displays the following error message:

General vSAN error.

The /var/log/vmware/vsphere-ui/logs/vsan-plugin.log file records the following messages:

ServerFaultCode: General vSAN error.
faultMessage: Configuration of fault domains is not supported on a vSAN cluster with capacity reservation enabled.

This issue affects environments using vSAN Capacity Reservation.

Environment

  • VMware vSAN 8.0
  • VMware vCenter Server 8.0

Cause

This issue occurs because the system attempts to configure fault domains while "Capacity Reservation" is enabled.
It may happen when previous cluster settings (such as reservation settings) persist, for example, after restoring vCenter Server 8.0U1 from a file-based backup.

Resolution

To resolve the conflict in the existing cluster settings, create a new cluster and reconfigure the vSAN cluster.

  1. Create a new cluster: Create a new cluster in the inventory
  2. Move hosts: Move the ESXi hosts to the new cluster.
  3. Configure vSAN: Configure vSAN on the new cluster.
  4. Cleanup: After deleting the existing (problematic) cluster, you can rename the new cluster to the original name if desired.