LDAP users unable to log in to VMware Cloud Director Portal with message "Authentication Error"
book
Article ID: 420439
calendar_today
Updated On:
Products
VMware Cloud Director
Issue/Introduction
When attempting to access VCD tenant / provider portals using user accounts from the configured LDAP, fails to log the user in with error "Authentication Error"
Upon attempting to sync the LDAP server on the VCD tenant portal : Sync task fails with error message [LDAP: error code 49 - 8009 0306: LdapErr: DSID-OC09 0527, comment: AcceptsecurityContext error, data 775, v4563]
Attempting to test connection to the LDAP server from VCD portal using the configured bind user credentials fails with error message "Connection to the LDAP server failed"
Environment
VMware Cloud Director 10.x
Cause
VMware Cloud Director is unable to validate / sync user accounts from the configured LDAP due to bind user account having been disabled on the LDAP server.
This could be caused by various reasons:
Bind user being invalid / disabled / expired / credentials change
LDAP server conventionality issue - Port, SSL, route, DNS misconfigured.
Resolution
Log in the VCD Tenant / Provider portal using system Administrator / tenant administrator account.
Navigate to Administration.
From the secondary left panel, under Identity Providers, select LDAP. The current LDAP settings are displayed.
On the LDAP Settings tab, click Edit. The Edit LDAP Options dialog box.
Validate the configuration details : hostname, port, bind user and password, etc.
Save the configuration
Attempt the Test the connection :
Enter the bind user password: The connection should return successful and verify the same by attempting to list details of other users.
If the Connection test fails,:
Ensure the LDAP server is up and accessible from VCD machine.
Ensure valid credentials are to be used for bind user who is active/ enabled on the LDAP.
Once test is successful, trigger a Sync for the LDAP server: Validate that the task completes successfully.