SRM (Spectrum Report Manager is not able to connect to the Archive Manager
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SRM (Spectrum Report Manager is not able to connect to the Archive Manager

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Article ID: 420429

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Updated On:

Products

Network Observability Spectrum

Issue/Introduction

2025-11-24 09:21:03,153 [PoolThread-2: HistoricalUpdateJobPool => BackEndEventDataModel.HistoricalUpdateJob] INFO  com.aprisma.debuglog -  (SLM_STAT_EVENT) - HUJob.waitForConnection (0x100000):  rechecking Archive Man connection every 1 minute(s)
2025-11-24 09:21:32,737 [SRM/AlarmHandler1048576/bucketReader] WARN  com.aprisma.errorlog - Unable to obtain connection to ArchMgr for domain 0x100000.
2025-11-24 09:21:32,737 [SRM/AlarmHandler1048576/bucketReader] WARN  com.aprisma.errorlog - Retrying connection in 60 seconds.
2025-11-24 09:21:33,556 [SRM/LandscapeManager/LandscapeThread_0] INFO  com.aprisma.debuglog -  (SRM_Events) - (INFO) - No connection to the domain, so we increment the retry counter.
2025-11-24 09:21:33,556 [SRM/LandscapeManager/LandscapeThread_0] WARN  com.aprisma.errorlog -  (SRM_Events) - (WARN) - Unable to obtain connection to ArchMgr for <SpectroSERVER>.  Retrying.

Environment

DX NetOps Spectrum: Any release

Cause

The Archive Manager was started by the root account

more $SPECROOT/SS/DDM/ARCHMGR.OUT
Nov 24 09:07:57 : ArchMgr started as user 'root'
Nov 24 09:07:57 : ArchMgr validating database.
Nov 24 09:07:58 : ArchMgr successfully connected to MySQL daemon
Nov 24 09:07:58 : ArchMgr loaded DDM database with landscape handle 0x100000

Resolution

Stop the SpectroSERVER, Archive Manager, and processd and then start them again.

$SPECROOT/bin/stopSS.pl    (as root account)

systemctl stop processd    (as root account)

systemctl start processd    (as root account)

Ensure the files under $SPECROOT/SS/ and $SPECROOT/SS/DDM directories are owned by Spectrum Install Owner account

$SPECROOT/bin/startSS.pl    (as spectrum account)