TCP/IP stack corruption on Guest OS causing loss of network to the virtual machine
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TCP/IP stack corruption on Guest OS causing loss of network to the virtual machine

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Article ID: 420423

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • The virtual machine is network-isolated and unreachable via the network.
  • The virtual Machine's web console is active, permitting successful login to the Guest OS.
  • The virtual machine can not reach peer VM's within same subnet running on the same ESXi host.
  • On the Guest OS NIC status shows warning message "Unidentified network" or "No internet access".
  • A command-line ping from the Guest OS to the default gateway IP address is failing/unsuccessful.

  • Packet capture on the virtual machine's port group on ESXi host confirms a complete absence of egress network traffic originating from the Guest OS.
  • Refer the pktcap-uw tool to identify the switch port to perform packet captures on ESXi host.

  • Above packet capture confirms there are no packets being received at VM switchport.

Environment

VMware vSphere ESXi

Cause

The fault condition is attributable to TCP/IP stack corruption affecting one or more vNIC's within the Guest Operating System.

Resolution

  • Contact guest OS vendor to fix the issue.

Workaround:

  • Collect the virtual machine network configuration information.
    • IP Address
    • Subnet mask
    • Gateway
    • DNS IPs.
  • Delete the existing vNIC adapter for the problematic VM through vCenter console and create new vNIC.
    • Configure network from guest OS by assigning IP address to the newly created vNIC.
  • Test the connectivity of the virtual machine.

Additional Information

If the resolution or workaround does not resolve the issue, open a Networking Support Case with Broadcom Support using the instructions at Creating and managing Broadcom support cases to determine the best course of action.