Symantec VIP Mobile PUSH user experience
search cancel

Symantec VIP Mobile PUSH user experience

book

Article ID: 420356

calendar_today

Updated On:

Products

VIP Service

Issue/Introduction

Users may receive different experiences when authenticating using Symantec VIP Mobile PUSH requests

Cause

Different authentication methods may result in different PUSH notifications that the user may experience. The VIP Radius authentications (through VIP Enterprise Gateway) are mostly hard coded. While custom Web API authentications have more flexibility in the request parameters.

Resolution

In order to provide a more consistent user experience, the Web API PUSH notifications will need to be modified to align with the Radius PUSH notifications.

Below are some details about VIP PUSH that map to the API parameters:

From VIP Enterprise Gateway From Custom API Script
Header text Header text / Organization name?
Body message Body message
Organization name Organization name?
More Body Text (actually profile text)  

You can change these, but it is an API-level change and are not available in the VIP Enterprise Gateway configuration.

VIP Enterprise Gateway customers are not ENTIRELY without customization. You can change part of the body text in the UI or in the config file:

  • In config file: SecondFactorModule.pushMessage
  • In the UI: VIP Enterprise Gateway -> Validation -> pick_one -> “Remote Access Service Name/URL”
  • The portion that can be changed is in RED, above.

VIP Web API script:

authenticateUserWithPush()  
display.message.title Ninja Zone
display.message.text Hello IPAS!
display.message.profile Ninja portal