Splunk Nozzle tile fails with "bash: line 1: ./splunk-firehose-nozzle: Permission denied"
search cancel

Splunk Nozzle tile fails with "bash: line 1: ./splunk-firehose-nozzle: Permission denied"

book

Article ID: 420350

calendar_today

Updated On:

Products

VMware Tanzu Application Service

Issue/Introduction

When attempting to deploy the splunk nozzle application in the Splunk Nozzle tile, it fails with:

bash: line 1: ./splunk-firehose-nozzle: Permission denied

Environment

Splunk Nozzle Tile

Cause

This issue has been observed in some environments when upgrading the Splunk Nozzle tile.

Resolution

One workaround for this is to perform the following:

  1. Delete the Splunk Nozzle Tile from the Ops Manager UI
  2. Apply Changes, removing the tile.
  3. Run bosh clean-up. Validate that the splunk nozzle release has been removed with bosh releases | grep splunk
  4. Install Splunk Nozzle tile again.
    NOTE: When you install the new Splunk tile, you will need to select the "Recreate VMs deployed by the BOSH Director" checkbox in the BOSH Director tile, Director Config tab and Apply Changes on the Splunk tile, the TAS tile, and any Isolation Segment or other tiles that need to use Splunk.