startTLS Not Working With Mail Trigger
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startTLS Not Working With Mail Trigger

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Article ID: 420186

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

When attempting to configure SMTP email in CA Process Automation using the 'SMTP SSL' and start TLS configuration options, the mail trigger does not work.

ITPAM log shows the following error:

ERROR [com.optinuity.c2o.service.serviceoperation.mailserviceoperation.MapiAlertServiceOperationRunner] [94-fa3374801135] Could not send the message
java.lang.Exception: Unable to send message to all the addresses

Environment

CA Process Automation 4.4.x

Cause

 Problem is related to a Java restriction that prevents the socket from converting to SSL after initiating a plaintext connection, even though the process was designed to upgrade to encryption.

Resolution

startTLS certification is on the certification roadmap for ITPAM 4.4 CP05.

Unfortunately, as of December 2025, there is no current ETA as to when CP05 will be published.

Additional Information

Recommended to use SSL instead of startTLS since SSL uses TLS version 1.2, but startTLS establishes an unencrypted connection first and only upgrades to encryption after an explicit command. Therefore, SSL is more secure than startTLS.