ConnectALL - Not able to start Core service after 4.0 upgrade
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ConnectALL - Not able to start Core service after 4.0 upgrade

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Article ID: 420065

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Updated On:

Products

ConnectAll On-Prem ConnectALL

Issue/Introduction

After upgrading ConnectALL to v4.0 we are not able to start core services.

Environment

4.0

Cause

Installation logs shows below error. The following failure is the cause for the remaining changesets not being executed.

[ERROR] com.install4j.runtime.beans.actions.control.RunScriptAction [ID 31605]: ChangeSet liquibase/changelog/v03_10-saml.xml::copy-idp-metadata-to-db::cn669600 encountered an exception.
liquibase.exception.UnexpectedLiquibaseException: liquibase.exception.CustomChangeException: java.lang.RuntimeException: java.io.FileNotFoundException: /appvol/ConnectALL/Core/../UI/tomcat/conf/ConnectAll/saml/images/appvol/ConnectALL/UI/tomcat/conf/ConnectAll/images/azure.png (No such file or directory)

Resolution

Addressed the error by correcting file permissions followed by rerunning ConnectALL 4.0 upgrade.