SSH connection refused for NSX Edge post reboot
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SSH connection refused for NSX Edge post reboot

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Article ID: 420061

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Post reboot of edge the SSH is not working.
  • Failure to enable can result in the error below when attempting to connect:
    Network error: Connection refused

Environment

VMware NSX-T Data Center
VMware NSX

Cause

Starting the SSH service will not persist across the reboot. The reboot of the NSX edge may stop the SSH service during boot if start-on-boot is not set.

Resolution

 

  • Log in to the management domain vCenter Server using the vSphere Client.

  • Locate the NSX Edge Virtual Machine, right-click it, and select Launch Web Console.

  • Log in to the console using the admin credentials:

 

  • To validate the service status and the start-on-boot configuration by running:

    get service ssh
  • To enable the SSH service, run the following command:

    start service ssh
  • To ensure the SSH service persists after the Edge node reboots, issue the following command

    set service ssh start-on-boot
  • To validate the service status and start on boot configuration, run the below command:
    get service ssh
    Service name: ssh
    Service state: stopped
    Start on boot: True
    Root login: enabled

 

Additional Information

documentation for enabling SSH during deployment  is available in the Broadcom TechDocs

Enable SSH access to NSX Edge Nodes

You may encounter the following issue when enabling SSH via the NSX UI:

Error in UI when modifying edge nodes : "Modification of some properties of an edge node is not allowed via NSX Manager. Kindly use CLI to modify these properties: node_user_settings and allow_ssh_root_login (Error code: 16028)