profiles not synchronizing to other hubs - profile shows INVAL in hub log
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profiles not synchronizing to other hubs - profile shows INVAL in hub log

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Article ID: 419788

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

You have created one or more profiles in Infrastructure Manager (View->Manage Profiles) and are experiencing one or more of the following symptoms:

  • Users logging in to the primary hub have their profiles applied appropriately, but when logging in directly to other hubs, profiles are not loaded.
  • hub.log on those other hubs shows the following error for the profiles:
     
    hub: Profile - (profile name)             ## bytes (INVAL)
  • the (profilename).pcf file is present in the /hub/profiles/ folder on the primary hub but not the secondary hub(s)

 

 

 

Environment

DX UIM - 23.4.6 or prior
hub 23.4.6 or prior

Cause

The process that synchronizes the profiles can get stuck in a situation where two hubs are asking each other for the same profile but neither one of them has it, causing an infinite loop.

Resolution

As a workaround, restart each hub that doesn't have the profile, and wait a few hours. Normally after one or more restarts, the profiles will eventually synchronize - in hub 23.4.6 and prior this can take approximately 3 hours.

If the profiles have not synchronized after 3 hours, restart the hub(s) again.

This will be resolved in hub 23.4.7 (approximate ETA March 2026 - subject to change)