The pgpool service in VMware Identity Manager 3.3.x shows ' No such file or directory'
search cancel

The pgpool service in VMware Identity Manager 3.3.x shows ' No such file or directory'

book

Article ID: 419757

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

The pgpool service is using the script in /etc/init.d/pgService , but the commands to start , stop, or status fail

For example you observe:

/etc/init.d/pgService status
/etc/init.d/pgService: line 26: /etc/sysconfig/pgpool: No such file or directory

Environment

VMware Identity Manager 3.3.x

Cause

The script uses a different MD5SUM index from other nodes in the cluster, and therefore cannot find the file to start, stop , or display the service status

Resolution

1. Open SSH to each node in the IDM cluster and run:

md5sum /etc/init.d/pgService

2. Compare the output across all nodes to ensure they all match.

NOTE: If any of the nodes have a mismatch, navigate to the file /etc/init.d/ on the offending node, and perform a secure copy pulling the correct pgService filesystem from the PRIMARY node:

scp <exampleFQDN.host.com>:$(pwd)/pgService

3. Run the MD5SUM to double check pgService file is now correct on each node