Email not synced for LDAP users in VCF operations from vIDB, users not able to login using only the email address.
search cancel

Email not synced for LDAP users in VCF operations from vIDB, users not able to login using only the email address.

book

Article ID: 419686

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

After deploying vIDB as a separate appliance in VCF fleet manager and adding LDAP as an Identity Source. Users and Groups get synced but the users do not contain the Email address in VCF Operations UI ->Access Control page.

Users cannot login with their email address as username in VCF Operations.

Environment

VCF Operations 9.0.x

Cause

There is a requirement for 'username@domain' login format in 9.0.x versions. users must manually append the domain to their email address for successful login.

Resolution

  • There is a known issue in VCF Operations version 9.0.x where emails are not correctly synced from VIDB to VCF Operations. This issue is resolved in version 9.1.
  • In 9.0.x versions, when emails use different domains, successful login requires:
    • LDAP sync mapping where username (VIDB) is equal to mail (LDAP).
    • Logging in with a format like '[email protected]@rainpole.com' where example.com is their email server and rainpole.com is their domain

The problem arises when customers want to log in using only [email protected]. This has been resolved in version 9.1, which allows login with just the username if it uniquely identifies the user.