Error "connection timed out" when configuring SMTP on Aria Operation for logs using smtp.azurecomm.net and sending a test email
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Error "connection timed out" when configuring SMTP on Aria Operation for logs using smtp.azurecomm.net and sending a test email

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Article ID: 419674

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Performing a send test email when configuring SMTP in Aria Operations for logs while using Azure Communication Services (smtp.azurecomm.net) fails with Connection time out.
  • Checking port connectivity between Aria Operations for logs node and smtp.azurecomm.net fails.

    [Root@vrli]# curl -v smtp.azurecomm.net:587
    Host smtp.azurecomm.net:587 was resolved.
    * IPv6: (none)
    * IPv4: ###.###.###.###
    *   Trying ###.###.###.###:587...
    * connect to ###.###.###.### port 587 from ###.###.###.### port 35842 failed: Connection timed out
    * Failed to connect to smtp.azurecomm.net port 587 after 129438 ms: Could not connect to server
    * closing connection #0
    curl: (28) Failed to connect to smtp.azurecomm.net port 587 after 129438 ms: Could not connect to server

Environment

Aria Operations for logs 8.18.x

Cause

  • TLS/StartTLS has to be enabled while configuring SMTP instance using smtp.azurecomm.net
  • VMware Aria Operations for logs only uses port 587 for secure TLS and hence port 587 has to be open between Aria Operations for logs nodes and smtp.azurecomm.net

Resolution

  • Ensure connectivity between Aria Operations for logs nodes and smtp.azurecomm.net on port 587 is present.

Additional Information

How to set up SMTP AUTH client submission for Azure Communication Services