Performing a send test email when configuring SMTP in Aria Operations for logs while using Azure Communication Services (smtp.azurecomm.net) fails with Connection time out.
Checking port connectivity between Aria Operations for logs node and smtp.azurecomm.net fails.
[Root@vrli]# curl -v smtp.azurecomm.net:587 * Host smtp.azurecomm.net:587 was resolved. * IPv6: (none) * IPv4: ###.###.###.### * Trying ###.###.###.###:587... * connect to ###.###.###.### port 587 from ###.###.###.### port 35842 failed: Connection timed out * Failed to connect to smtp.azurecomm.net port 587 after 129438 ms: Could not connect to server * closing connection #0 curl: (28) Failed to connect to smtp.azurecomm.net port 587 after 129438 ms: Could not connect to server
Environment
Aria Operations for logs 8.18.x
Cause
TLS/StartTLS has to be enabled while configuring SMTP instance using smtp.azurecomm.net
VMware Aria Operations for logs only uses port 587 for secure TLS and hence port 587 has to be open between Aria Operations for logs nodes and smtp.azurecomm.net
Resolution
Ensure connectivity between Aria Operations for logs nodes and smtp.azurecomm.neton port 587 is present.