Error: "Unable to reach tca service from ingress. Please check the status of the service by accessing the cluster" when launching the TCA-CP UI Page
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Error: "Unable to reach tca service from ingress. Please check the status of the service by accessing the cluster" when launching the TCA-CP UI Page

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Article ID: 419662

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

  • Unable to access TCA control plane through UI.
  • Access through SSH and CLI operations are successful.
  • tca-api-##-## pod is in crashloopBackoff status
  • pod details authentication error:

    [http-nio-8443-exec-6, , , TxId: ] ERROR c.v.v.h.a.HybridityAccessDeniedHandlerImpl- Sending Response Error 403 for /tca/global/api/v1/sessions
    [http-nio-8443-exec-3, , , TxId: ] WARN  c.v.t.w.s.TcaSecurityAnnotationEvaluator- Access denied to logout authentication is required
    [Timer-0, , , TxId: ] INFO  c.v.v.h.a.SessionPurgingMapSessionRepository- Started Purging session. Current Map count 0
    [http-nio-8443-exec-8, , , TxId: ] INFO  c.v.t.d.AuthenticationServiceByVc- Admin service config:

 

 







Environment

TCA 3.x

Cause

  • The pod is unable to state due to authentication failure with the vCenter Server.
  • This issue occurs when the kublet certificate was not rotated successfully after renewing the vCenter certificate renewal.

 

Resolution

Rotate the kubelet certificate using the script provided in KB Error: failed to run Kubelet: unable to load bootstrap kubeconfig: stat /etc/kubernetes/bootstrap-kubelet.conf: no such file or directory