Powering on a virtual machine fails with the message "Unable to enumerate disks"
search cancel

Powering on a virtual machine fails with the message "Unable to enumerate disks"

book

Article ID: 419644

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • When powering on a virtual machine from the vSphere Client, the message "Unable to enumerate disks" appears in the upper right corner of the screen and the operation fails.
  • Opening the "Edit Settings" dialog for the virtual machine reveals a hard disk listed as 0 MB in size.
  • Expanding the item for the "hard disk" listed as 0 MB in size reveals that the correct vmdk file is not listed under "Disk File".

Environment

VMware vSphere ESXi 8.x

Cause

An invalid path has been set as the "Disk File" for the virtual machine's hard disk.

Resolution

In the "Edit Settings" dialog box, remove the hard disk displayed as 0 MB using "Remove device".
Then proceed to "ADD NEW DEVICE" -> "Existing Hard Disk" and select the correct vmdk file.

For detailed instructions on adding an existing hard disk to a virtual machine, see the "Add an Existing Hard Disk to a Virtual Machine" section in the following document:

How do I add a hard disk to a virtual machine