First Name and Last Name shows empty for VCF SSO JIT Provisioned users from Microsoft Entra ID
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Article ID: 419641
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Updated On:
Products
VMware vCenter ServerVMware Cloud Foundation
Issue/Introduction
VCF SSO is configured for Microsoft Entra ID identity provider with below Authentication specification:
Identity Source -> Microsoft Entra ID
Authentication Method -> OIDC
Provisioning Method - JIT
First Name and Last Name for the OIDC provisioned users shows blank values when verifying the users from vSphere Client -> Administration -> Users and Groups :
User Attributes are properly configured as below in VCF SSO settings :
userName -> preferred_username
firstName -> given_name
lastName -> family_name
Environment
VCF 9.x
Cause
This issue is caused when the Optional Claims are not configured in Microsoft Entra ID App Registration in Azure Portal.
Resolution
Add the following Optional Claims for the Microsoft Entra ID OIDC App Registration used for VCF SSO in Azure Portal.
Login to Azure Entra ID portal.
Select the Entra OIDC App Registration.
Click on Token Configuration.
Click on Add optional claim.
Select Token type as ID.
Select "family_name" & "given_name".
Click Add.
Sample configuration:
Re-login to vCenter Server with the Entra ID account.