Aria Operations upgrade from version 8.18.3 to 8.18.5 is stuck at stage 3 of 14
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Aria Operations upgrade from version 8.18.3 to 8.18.5 is stuck at stage 3 of 14

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Article ID: 419538

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

The upgrade cannot proceed because the management pack upgrade process is stuck. You will observe errors like the ones below in vcopsPakManager.root.post_apply_adapter.log

Log location: /storage/vcops/log/pakManager/vcopsPakManager.root.post_apply_adapter.log

DEBUG [44983] - vcopsPakManager.installSolution:3438 - Installing solution: /storage/db/casa/pak/dist_pak_files/VA_LINUX/NetworkInsightAdapter-818524967135.pak
...
DEBUG [44983] - vcopsPakManager.waitForTaskToComplete:3341 - Task state: RUNNING for URL: https://localhost/suite-api/api/tasks/######-####-###-####-##########
DEBUG [44983] - vcopsPakManager.waitForTaskToComplete:3351 - job: https://localhost/suite-api/api/tasks/######-####-###-####-########## is still running after: 0.0 seconds
DEBUG [44983] - vcopsPakManager.checkResponse:3304 - Expected response code: 200
DEBUG [44983] - vcopsPakManager.checkResponse:3305 - Response code: 429
DEBUG [44983] - vcopsPakManager.checkResponse:3306 - Response body: <!doctype html><html lang="en"><head><title>HTTP Status 429 – Too Many Requests</title><style>
DEBUG [44983] - vcopsPakManager.HandleError:610 - Resource result is set
DEBUG [44983] - vcopsPakManager.UpdateResultsFile:531 - Entering update the results file with the result: "Failed to install adapters", exit code: "1", action: "apply_adapter"
...
DEBUG [44983] - vc_ops_logging.logDebug:266 - Key: "pak_manager.adapter_install_failed" value is: "Adapter install failed"
ERROR [44983] - vcopsPakManager.HandleError:630 - Exiting with exit code: 1, message: Expected response code: 200, but got: 429, exiting--exiting

Environment

Aria Operations 8.18.x

Cause

The upgrade is unsuccessful due to excessive API requests sent to Aria Operations, resulting in repeated 429 (Too Many Requests) errors.

Resolution

Analyze the /storage/log/vcops/log/suite-api/localhost_access_log.txt Log to identify the IP generating excessive API requests, temporarily block its calls, and then retry the upgrade.