Logging stops on all log files and hosts might become unresponsive
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Logging stops on all log files and hosts might become unresponsive

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Article ID: 419488

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Updated On:

Products

VMware vSphere ESXi 8.0

Issue/Introduction

  • In ESXi, logging stops on all log files.
  • The issue might occur as the result of multiple syslog reloads.

--/var/log/.vmsyslogd.err
YYYY-MM-DDTHH:MM:SS vmsyslog        : CRITICAL] vmsyslogd daemon starting (#######)
YYYY-MM-DDTHH:MM:SS vmsyslog.main   : ERROR   ] switching to normal mode from init mode
YYYY-MM-DDTHH:MM:SS vmsyslog.main   : ERROR   ] reloading (#######)
YYYY-MM-DDTHH:MM:SS vmsyslog.main   : ERROR   ] reloading (#######)
YYYY-MM-DDTHH:MM:SS vmsyslog.main   : ERROR   ] reloading (#######)
YYYY-MM-DDTHH:MM:SS vmsyslog.main   : ERROR   ] reloading (#######)
YYYY-MM-DDTHH:MM:SS vmsyslog.main   : ERROR   ] reloading (#######)

Environment

VMware ESXi 8.0

Cause

A rare deadlock situation in the ESXi log daemon vmsyslogd might cause logging to stop on all log files.

As a result, the hosts might become unresponsive.

Resolution

This issue is resolved in the VMware ESXi 8.0 Update 3e (Build 24674464)

Additional Information

VMware ESXi 8.0 Update 3e Release Notes
https://techdocs.broadcom.com/us/en/vmware-cis/vsphere/vsphere/8-0/release-notes/esxi-update-and-patch-release-notes/vsphere-esxi-80u3e-release-notes.html